Do you have "Show Signatures" turned off in your user/account settings?...