PDA

View Full Version : Darn heated buckets!



dmalbone
Dec. 16, 2010, 10:38 AM
Last night was my first night of pure heaven. The water is installed (and working!) and I finally have running water in the barn! We have a heated "muck bucket" in each paddock off the stalls plus a heated bucket hanging in the stall. Today is my ONE early work day of the week where I have to feed at 6 and leave the house at 6:30 (I'm NOT a morning person... especially when it's 5 degrees out). I went out there and was amazed how much my oldster drank. He's not a big drinker, but gets tons of water in his cube mush so I generally don't worry. I filled his bucket 3/4 full and it only had a couple inches in the bottom. So excitedly (it was my first morning using the new pump after all!) I fill up a bucket and pour it in there, only to hear water splashing to the ground below. :mad: I walked in there and saw the bucket was smashed. I ran out and unplugged it and got it dumped and out of the stall. Somehow the front and bottom were smashed and water was running out from between two layers of the bucket. I didn't even realized they were multi-layered!

He can be a turd, but he's 21 yrs old and mostly just lazy. He's never broken a bucket in his life, but this was the first winter I used the SLT logo'ed heated buckets. I saw they're not on their site anymore so I wonder if they were flimsy or had complaints. That's what I get for being a cheapo apparently and buying the one that was a few $ cheaper. It was pretty creepy though because the few inches of water wasn't frozen in the bottom so I am assuming it didn't shut off. :eek:

King's Ransom
Dec. 16, 2010, 06:04 PM
I am sooo sorry you had trouble with your buckets -- and on the first night! I have four that I bought from the local farm store, don't know the brand right off the top of the my head. They were about $40 each as I recall.

No problems. I've only had them for about 3 weeks, but I do sooo love my heated buckets!

Are you going to try again?