PDA

View Full Version : Cleaning original T-boots...



cmth
Sep. 5, 2009, 09:20 PM
Help! I have a pair of original Equi-fit T Boots, the ones with the EVA outer shell and I can not get them clean. I have tried soap and water with a scrubby and Armorall wipes. I feel like I can scrub all day and they are still going to show dirt. Normally this is not a probelm but I am doing a clinic with George Morris in a few weeks so they have to be clean.

Has anyone found anything that makes them look like new?

Riley0522
Sep. 6, 2009, 12:08 PM
Use a Lysol wipe on them.

Jumphigh83
Sep. 6, 2009, 02:02 PM
You may have scratched them by scrubbing ...just a thought...my problem with the old model is the god awful SMELL they get...like cat pee....:eek:

Tap2Tango
Sep. 6, 2009, 02:18 PM
You may have scratched them by scrubbing ...just a thought...my problem with the old model is the god awful SMELL they get...like cat pee....:eek:

Ughhh I know. We had a client that used them and the whole trunk smelled like cat pee! EWWW I would never get t-boots because of this!

M. O'Connor
Sep. 6, 2009, 03:00 PM
What I do with mine is: toss them in the washer...tumble them in the dryer for a bit, finish drying them in the sun...then polish them with a dab of Show Sheen.

Riley0522
Sep. 6, 2009, 07:12 PM
You may have scratched them by scrubbing ...just a thought...my problem with the old model is the god awful SMELL they get...like cat pee....:eek:

I have the originals and they don't smell like cat pee and they have been washed :confused: They are the newer version with the removal liners though...

Jumphigh83
Sep. 6, 2009, 07:18 PM
Trade ya!!!:winkgrin: